Logo Objects ile fatura kesmek

1 yılı aşkın bir süredir logo tiger kullanıyorum/z öncelikle copy paste olayı ile hemen hemen her işimizi görüyor. logo da objects kullanmak istiyorsanız ilk olarak lisansınızın olması gerekiyor. register felan nette bir çok sitede var ben sadece delphi ile pek az örnek var küçük bir örnekte ben sunmak istedim. döküman diye fazla kıvranmayın tablo isimleri harici pek fazla döküman bulamazsınız üretici firma ise sadece çözüm ortaklarına destek veriyor. benim tavsiyem ne yapacaksanız fiş fatura vs. logoda yapın ve araçlar veri aktarımı ile dışarı xml atın ve alanları inceleyin aşağıdaki örnek size yol gösterecektir. unutmadan saati herzaman pack etmek zorundasınız.

var
data: IData;
datalines: UnityObjects_TLB.ILines;
zaman: OleVariant;
begin
data := Logo.NewDataObject(doSalesInvoice);
data.New;
data.DataFields.FieldByName('TYPE').Value := 9;
data.DataFields.FieldByName('NUMBER').Value := //Fatura No
data.DataFields.FieldByName('DOC_NUMBER').Value := // Belge Numarası
data.DataFields.FieldByName('AUXIL_CODE').Value := 'AUTO';
data.DataFields.FieldByName('DATE').Value := //Tarih
data.DataFields.FieldByName('DOC_DATE').Value := // Tarih
Logo.PackTime(12, 12, 12, zaman);
data.DataFields.FieldByName('TIME').Value := zaman;
data.DataFields.FieldByName('ARP_CODE').Value := // Müşteri Kodu
data.DataFields.FieldByName('POST_FLAGS').Value := 247;
data.DataFields.FieldByName('PAYMENT_CODE').Value := // Ödeme Planı
data.DataFields.FieldByName('SALESMAN_CODE').Value := // Satıcı
data.DataFields.FieldByName('NOTES1').Value := //Açıklama
data.DataFields.FieldByName('SOURCE_WH').Value := // Ambar Kodu
data.DataFields.FieldByName('DIVISION').Value := //Depo Kodu
datalines := data.DataFields.FieldByName('TRANSACTIONS').Lines;
datalines.AppendLine;
datalines[0].FieldByName('TYPE').Value := 4;
datalines[0].FieldByName('MASTER_CODE').Value := //Stok Kodu
datalines[0].FieldByName('QUANTITY').Value := //Adet
datalines[0].FieldByName('PRICE').Value := //B.Fiyat
datalines[0].FieldByName('UNIT_CODE').Value := 'ADET';
datalines[0].FieldByName('VAT_RATE').Value := //KdV
data.Post

Mikrotik ile birden fazla adsl hattını birleştirme

Bu işlere ücretli destek verdiğim için fazla detaya girmiyorum.

 /ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=pppoe-out1
add action=masquerade chain=srcnat disabled=no out-interface=pppoe-out2
/ip firewall mangle
add action=mark-connection chain=input disabled=no in-interface=pppoe-out1 new-connection-mark=wan1_conn passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=pppoe-out2 new-connection-mark=wan2_conn passthrough=yes
add action=mark-routing chain=output connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes
add action=mark-routing chain=output connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=wan1_conn disabled=no in-interface=Local new-routing-mark=to_wan1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no in-interface=Local new-routing-mark=to_wan2 passthrough=yes
add action=accept chain=prerouting disabled=no in-interface=pppoe-out1
add action=accept chain=prerouting disabled=no in-interface=pppoe-out2
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_wan2 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out2 scope=30 target-scope=10
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=209.244.0.3,209.244.0.4 

Logo Tiger Hesap Özeti SQL

DSYB Bilgi Yönetim Sisteminde Kullanmış olduğım Cari hesap özetinin SQL Kodları

ALTER FUNCTION [dbo].[GET_LOGO_EKSTRE] ( -- Add the parameters for the function here
                                         @REF INTEGER )
RETURNS TABLE
AS
RETURN
    ( 
    
    SELECT  DATE_ AS TARIH ,
        TRANNO AS BELGENO ,
        LINEEXP ,
        DEBIT AS BORC ,
        CREDIT AS ALACAK
FROM    BDSYB2014.dbo.LV_001_01_CLEKSTRE
WHERE   CLIENTREF = @REF
        AND TRCODE NOT IN ( 38, 39 )
UNION ALL
SELECT  BDSYB2014.dbo.LV_001_01_CLEKSTRE.DATE_ ,
        BDSYB2014.dbo.LV_001_01_CLEKSTRE.TRANNO ,
        CONVERT(VARCHAR, BDSYB2014.dbo.LV_001_01_STLINE.AMOUNT, 102)
        + '- Ad. ' + BDSYB2014.dbo.LV_001_01_STLINE.LINEEXP AS ACIKLAMA ,
        ( SELECT    VATAMNT + VATMATRAH
          FROM      BDSYB2014.dbo.LG_001_01_STLINE
          WHERE     BDSYB2014.dbo.LG_001_01_STLINE.LOGICALREF = BDSYB2014.dbo.LV_001_01_STLINE.LOGICALREF
        ) AS BORC ,
        CASE ( SELECT TOP 1
                        PAIDINCASH
               FROM     BDSYB2014.dbo.LG_001_01_INVOICE
               WHERE    LOGICALREF = BDSYB2014.dbo.LV_001_01_CLEKSTRE.SOURCEFREF
             )
          WHEN 1
          THEN ( SELECT VATAMNT + VATMATRAH
                 FROM   BDSYB2014.dbo.LG_001_01_STLINE
                 WHERE  BDSYB2014.dbo.LG_001_01_STLINE.LOGICALREF = BDSYB2014.dbo.LV_001_01_STLINE.LOGICALREF
               )
          ELSE 0
        END AS ALACAK
FROM    BDSYB2014.dbo.LV_001_01_CLEKSTRE
        INNER JOIN BDSYB2014.dbo.LV_001_01_STLINE ON BDSYB2014.dbo.LV_001_01_CLEKSTRE.SOURCEFREF = BDSYB2014.dbo.LV_001_01_STLINE.INVOICEREF
WHERE   ( BDSYB2014.dbo.LV_001_01_CLEKSTRE.CLIENTREF = @REF )
        AND ( BDSYB2014.dbo.LV_001_01_CLEKSTRE.TRCODE IN ( 38, 39 ) )
    
    )

Logo Tiger Muhasebe Kodu Olmayan Stoklar

 SELECT  CODE, NAME,
(SELECT COUNT(*) FROM [dbo].[LG_001_CRDACREF]
WHERE TRCODE = 1 AND CARDREF =dbo.LG_001_ITEMS.LOGICALREF) AS SAY
FROM dbo.LG_001_ITEMS
WHERE (SELECT COUNT(*) FROM [dbo].[LG_001_CRDACREF]
WHERE TRCODE = 1 AND CARDREF =dbo.LG_001_ITEMS.LOGICALREF) <1
Genel kategorisine gönderildi