Logo Go / Tiger Hareketsiz Carileri Kullanımdışı yapma

Logo Go / Tiger Hareketsiz Carileri Kullanımdışı yapma


with bb as (SELECT LOGICALREF,CODE, DEFINITION_,( select count (CLIENTREF) from dbo.LV_115_01_CLEKSTRE where 

CLIENTREF = aa.LOGICALREF ) as say FROM dbo.LG_115_CLCARD as aa with (nolock) where CARDTYPE = 3 )

update LG_115_CLCARD set ACTIVE = 1 where LOGICALREF in ( select LOGICALREF from bb where say = 0)


Logo Tiger Depo Bazında Malzeme/Stok Durumları

Malzemlerin listesini depo bazında almak isterseniz aşağıdaki kodu kullanabilirsiniz.

SELECT     ITEMS.CODE, ITEMS.NAME, STINVTOT.INVENNO AS DEPO, SUM(STINVTOT.ONHAND) AS MIKTAR
FROM         LV_001_02_STINVTOT AS STINVTOT LEFT OUTER JOIN
LG_001_ITEMS AS ITEMS ON STINVTOT.STOCKREF = ITEMS.LOGICALREF
WHERE     (ITEMS.CARDTYPE = 1) AND STINVTOT.INVENNO = -1 /* Tüm Depolar için -1 */
GROUP BY ITEMS.CODE, ITEMS.NAME, STINVTOT.INVENNO, ITEMS.CARDTYPE
HAVING      (SUM(STINVTOT.ONHAND) <> 0)

Logo Objects ile fatura kesmek

1 yılı aşkın bir süredir logo tiger kullanıyorum/z öncelikle copy paste olayı ile hemen hemen her işimizi görüyor. logo da objects kullanmak istiyorsanız ilk olarak lisansınızın olması gerekiyor. register felan nette bir çok sitede var ben sadece delphi ile pek az örnek var küçük bir örnekte ben sunmak istedim. döküman diye fazla kıvranmayın tablo isimleri harici pek fazla döküman bulamazsınız üretici firma ise sadece çözüm ortaklarına destek veriyor. benim tavsiyem ne yapacaksanız fiş fatura vs. logoda yapın ve araçlar veri aktarımı ile dışarı xml atın ve alanları inceleyin aşağıdaki örnek size yol gösterecektir. unutmadan saati herzaman pack etmek zorundasınız.

var
data: IData;
datalines: UnityObjects_TLB.ILines;
zaman: OleVariant;
begin
data := Logo.NewDataObject(doSalesInvoice);
data.New;
data.DataFields.FieldByName('TYPE').Value := 9;
data.DataFields.FieldByName('NUMBER').Value := //Fatura No
data.DataFields.FieldByName('DOC_NUMBER').Value := // Belge Numarası
data.DataFields.FieldByName('AUXIL_CODE').Value := 'AUTO';
data.DataFields.FieldByName('DATE').Value := //Tarih
data.DataFields.FieldByName('DOC_DATE').Value := // Tarih
Logo.PackTime(12, 12, 12, zaman);
data.DataFields.FieldByName('TIME').Value := zaman;
data.DataFields.FieldByName('ARP_CODE').Value := // Müşteri Kodu
data.DataFields.FieldByName('POST_FLAGS').Value := 247;
data.DataFields.FieldByName('PAYMENT_CODE').Value := // Ödeme Planı
data.DataFields.FieldByName('SALESMAN_CODE').Value := // Satıcı
data.DataFields.FieldByName('NOTES1').Value := //Açıklama
data.DataFields.FieldByName('SOURCE_WH').Value := // Ambar Kodu
data.DataFields.FieldByName('DIVISION').Value := //Depo Kodu
datalines := data.DataFields.FieldByName('TRANSACTIONS').Lines;
datalines.AppendLine;
datalines[0].FieldByName('TYPE').Value := 4;
datalines[0].FieldByName('MASTER_CODE').Value := //Stok Kodu
datalines[0].FieldByName('QUANTITY').Value := //Adet
datalines[0].FieldByName('PRICE').Value := //B.Fiyat
datalines[0].FieldByName('UNIT_CODE').Value := 'ADET';
datalines[0].FieldByName('VAT_RATE').Value := //KdV
data.Post

Mikrotik ile birden fazla adsl hattını birleştirme

Bu işlere ücretli destek verdiğim için fazla detaya girmiyorum.

 /ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=pppoe-out1
add action=masquerade chain=srcnat disabled=no out-interface=pppoe-out2
/ip firewall mangle
add action=mark-connection chain=input disabled=no in-interface=pppoe-out1 new-connection-mark=wan1_conn passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=pppoe-out2 new-connection-mark=wan2_conn passthrough=yes
add action=mark-routing chain=output connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes
add action=mark-routing chain=output connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=\
both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=wan1_conn disabled=no in-interface=Local new-routing-mark=to_wan1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no in-interface=Local new-routing-mark=to_wan2 passthrough=yes
add action=accept chain=prerouting disabled=no in-interface=pppoe-out1
add action=accept chain=prerouting disabled=no in-interface=pppoe-out2
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_wan2 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out2 scope=30 target-scope=10
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=209.244.0.3,209.244.0.4